Payments Issue
Incident Report for FreshBooks
Resolved
Thanks for your patience, the incident has been resolved.
Posted over 1 year ago. Apr 13, 2017 - 16:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Apr 13, 2017 - 16:34 EDT
Identified
We’re experiencing issues processing payments through the Braintree, Authorize.net and Stripe payment gateways. A root cause has been identified and the team is working on a resolution at this time.
Posted over 1 year ago. Apr 13, 2017 - 16:32 EDT