FreshBooks - Unavailable
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue.
Posted Dec 24, 2020 - 09:03 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 23, 2020 - 21:00 EST
Investigating
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Dec 23, 2020 - 20:52 EST
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, and FreshBooks Payments.