Oops error when trying to access Billing and Upgrade page for some customers.
Incident Report for FreshBooks
Resolved
A solution has been implemented to address the issues surrounding user access to the upgrade page. Thank you for your patience and understanding.
Posted 8 months ago. Apr 18, 2018 - 13:40 EDT
Update
We are in the process of rolling out a fix for this issue. Thank you for your patience and understanding. Updates to follow.
Posted 8 months ago. Apr 17, 2018 - 15:08 EDT
Update
The FreshBooks team is continuing to work towards resolving this issue. Thank you for your patience.
Posted 8 months ago. Apr 16, 2018 - 15:20 EDT
Identified
The source of the "oops error" preventing some customers from accessing the Billing and Upgrade page has been identified. We are currently working on a resolution. Thank you for your patience and understanding. Updates to follow.
Posted 8 months ago. Apr 16, 2018 - 11:43 EDT
Investigating
We are currently aware of an "oops error" when some customers are trying to access the Billing and Upgrade page in their accounts. We are currently working to isolate the issue and resolve. Thank you for your understanding. Updates to follow.
Posted 8 months ago. Apr 16, 2018 - 10:35 EDT