FreshBooks - Stripe ACH and Direct Debit Transactions Failing
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Stripe ACH and Direct Debit transactions. Thank you for your patience while we worked to fix the issue.
Posted Feb 10, 2022 - 12:18 EST
Monitoring
We have fixed the issue impacting Stripe ACH and Direct Debit transactions in FreshBooks. We will continue to monitor the situation to ensure there are no further disruptions. Feel free to check back here for any further updates.
Posted Feb 10, 2022 - 11:50 EST
Identified
There’s currently an issue with Stripe ACH and Direct Debit transactions failing to process on FreshBooks. We’ve identified the problem and are working to fix it. However your Stripe ACH and Direct Debit transactions will not process at this time. Please check back for further updates.
Posted Feb 10, 2022 - 11:15 EST
This incident affected: FreshBooks.