Investigating
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 03, 2019 - 21:01 EDT
Monitoring
We are currently monitoring the issue affecting the availability of FreshBooks. We apologize for any inconvenience this may be causing. We will post another update when we have more information.
Posted 5 months ago. Jun 03, 2019 - 16:37 EDT
Investigating
We have received reports of an issue with FreshBooks availability and are working to resolve it as quickly as possible. We apologize for any inconvenience this may be causing. We will post another update when we have more information.
Posted 5 months ago. Jun 03, 2019 - 15:58 EDT
This incident affected: FreshBooks.