FreshBooks Classic Access
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored, New and Classic FreshBooks are now fully operational. We apologize for any inconveniences this may have caused.
Posted Oct 15, 2019 - 12:18 EDT
Update
We are continuing to investigate this issue.
Posted Oct 15, 2019 - 11:58 EDT
Investigating
Currently we are experiencing some degraded performance in Classic FreshBooks. We apologize for the inconvenience and are investigating the cause. Please check back for updates
Posted Oct 15, 2019 - 11:55 EDT