FreshBooks - Bank Import Partial Outage
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Bank Import in Europe. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jun 23, 2020 - 17:36 EDT
Monitoring
We have fixed the issue impacting Bank Import affecting some customers in Europe and will continue to monitor it to ensure there are no further interruptions. Feel free to check back here for any further updates.
Posted Jun 23, 2020 - 17:16 EDT
Investigating
There’s currently an issue with FreshBooks Bank Import affecting some customers in Europe. We're investigating the cause and will post further updates as soon as they are available.
Posted Jun 23, 2020 - 15:25 EDT
This incident affected: FreshBooks, FreshBooks Classic, and Automatic Expense Import.