FreshBooks - Down
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Aug 04, 2020 - 16:32 EDT
Monitoring
A fix has been implemented and FreshBooks accounts are accessible. We will continue monitoring the results.
Posted Aug 04, 2020 - 16:23 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2020 - 16:02 EDT
Investigating
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Aug 04, 2020 - 16:02 EDT
This incident affected: FreshBooks and FreshBooks Classic.