Freshbooks is down
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue.
Posted Aug 10, 2021 - 09:48 EDT
Update
FreshBooks Classic search issue has been resolved. We are continuing to monitor all our services
Posted Aug 10, 2021 - 09:19 EDT
Monitoring
This issue was resolved at 7:52 AM; however, FreshBooks Classic remains in degraded performance with search currently not operational.
Posted Aug 10, 2021 - 08:22 EDT
Identified
Team has identified the issue and the fix is being deployed
Posted Aug 10, 2021 - 07:54 EDT
Investigating
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.

Customers may be unable to access their accounts.
Posted Aug 10, 2021 - 07:49 EDT
This incident affected: FreshBooks and FreshBooks Classic.