New FreshBooks time entry search unavailable
Incident Report for FreshBooks
Resolved
Time entry search and the Time Entry Detail report are once again available. We apologize for the inconvenience.
Posted almost 2 years ago. Mar 17, 2017 - 11:18 EDT
Identified
Time Entry Search and the Time Entry Details search are unavailable while we implement some improvements.
Posted almost 2 years ago. Mar 16, 2017 - 12:34 EDT