FreshBooks Payments Currently Unavailable
Incident Report for FreshBooks
Resolved
The issue with FreshBooks Payments is now resolved. Thank you for your patience.
Posted over 1 year ago. Apr 27, 2017 - 14:39 EDT
Monitoring
The issue with FreshBooks Payments has now been identified and a fix has been implemented. We will continue to monitor the situation.
Posted over 1 year ago. Apr 27, 2017 - 14:27 EDT
Investigating
FreshBooks Payments is currently unavailable for processing. We are investigating the issue and apologize for any inconvenience. Please check back for updates.
Posted over 1 year ago. Apr 27, 2017 - 14:15 EDT