FreshBooks - Stale Search Results
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Search Results in FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jun 22, 2021 - 15:40 EDT
Identified
We are still continuing our work to resolve the issues affecting search results in FreshBooks. We will post further updates as soon as we have them.
Posted Jun 22, 2021 - 15:05 EDT
Update
We have identified the issue impacting search in FreshBooks and we're working towards a resolution for it. We will post an update as soon as everything is resolved.
Posted Jun 22, 2021 - 11:54 EDT
Investigating
There’s currently an issue with Stale Search Results on FreshBooks. This will affect Reports and general search in FreshBooks as the current results are delayed by a few hours. We’ve identified the problem and are working to fix it. Please check back for further updates.
Posted Jun 22, 2021 - 11:23 EDT
This incident affected: FreshBooks and FreshBooks Classic.