PDF Downloading Temporarily Unavailable for FreshBooks
Incident Report for FreshBooks
Resolved
Thank you for your patience. The issue preventing PDF downloads in FreshBooks has now been resolved.
Posted over 1 year ago. Jun 26, 2017 - 09:08 EDT
Identified
Currently we are experiencing issues with our PDF download option. We apologize for the inconvenience and are working to resolve it as quickly as possible.
Posted over 1 year ago. Jun 26, 2017 - 08:55 EDT