FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Apple Single Sign-On (SSO) on FreshBooks. Thank you for your patience while we worked to fix the issue.
Posted Oct 11, 2022 - 14:51 EDT
Monitoring
We have fixed the issue impacting Apple Single Sign-On (SSO) on FreshBooks, and will continue to monitor it to ensure no further impact to our customers.

Feel free to check back here for any further updates.
Posted Oct 06, 2022 - 18:17 EDT
Investigating
There’s currently an issue with Apple Single Sign-On (SSO) on FreshBooks. We are currently investigating the issue, however, you may be unable to sign in to your FreshBooks Account using Apple SSO at this time. If possible, please sign in using your FreshBooks email and password instead.

Please check back for further updates.
Posted Oct 06, 2022 - 17:48 EDT
This incident affected: FreshBooks.