FreshBooks - Access Issues

Incident Report for FreshBooks

Resolved

All issues regarding accessing FreshBooks have been resolved. FreshBooks and all of its features are available and ready to be used.
Posted Jun 13, 2025 - 03:34 EDT

Monitoring

We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Jun 12, 2025 - 18:50 EDT

Investigating

We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with your login, or intermittent loading issues across all areas of our app. This is related to the current Google outage.

We will post another update as soon as we have more information.
Posted Jun 12, 2025 - 14:46 EDT
This incident affected: FreshBooks.