FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Nov 30, 2020 - 18:46 EST
Monitoring
We have fixed the issue impacting FreshBooks PDF downloads, and will continue to monitor it to ensure there are no further issues. Feel free to check back here for any further updates.
Posted Nov 30, 2020 - 18:40 EST
Investigating
There’s currently an issue with PDF downloads on FreshBooks. We are investigating the problem and are working to fix it, however, you may be unable to use PDF downloads at this time. Please check back for further updates.
Posted Nov 30, 2020 - 18:03 EST