FreshBooks - Email Delivery
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Emails. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Dec 08, 2020 - 14:32 EST
Monitoring
We have fixed the issue impacting FreshBooks Emails, and will continue to monitor it to ensure there’s no further issues with Email Delivery. Feel free to check back here for any further updates.
Posted Dec 08, 2020 - 12:49 EST
Investigating
There’s currently an issue with Email Delivery on FreshBooks. Invoices, Estimates, Proposals, and Emailed Reports are not being delivered to their intended recipient(s) in a timely manner. We’ve identified the problem and are working to fix it. Please check back for further updates.
Posted Dec 08, 2020 - 12:41 EST
This incident affected: FreshBooks.