FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the PDF issue.
Posted Feb 28, 2022 - 18:27 EST
Monitoring
We have fixed the issue impacting FreshBooks' PDF feature, and will continue to monitor it to ensure there’s no further issue. Feel free to check back here for any further updates.
Posted Feb 28, 2022 - 18:17 EST
Investigating
There’s currently an issue with PDF features on FreshBooks. We’ve identified the problem and are working to fix it, however you may be unable to use PDF features at this time. Please check back for further updates.
Posted Feb 28, 2022 - 17:33 EST
This incident affected: FreshBooks.