FreshBooks Classic availably issues.
Incident Report for FreshBooks
Resolved
We have resolved the issue affecting the availability of FreshBooks Classic.
Posted 14 days ago. Dec 03, 2018 - 16:05 EST
Identified
We have identified an issue affecting the availability of FreshBooks Classic. We are working towards a resolution and will update when we have more information.
Posted 14 days ago. Dec 03, 2018 - 16:01 EST
This incident affected: FreshBooks Classic.