FreshBooks Classic and New FreshBooks - Down
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic and New FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 31, 2020 - 13:35 EDT
Investigating
FreshBooks Classic and New FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Mar 31, 2020 - 13:14 EDT
This incident affected: FreshBooks and FreshBooks Classic.