FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Sep 22, 2023 - 19:07 EDT
Monitoring
There’s currently an issue with the Account Billing Component of FreshBooks. We’ve identified the problem and are working to fix it, however, FreshBooks Account Creation, as well as any Account Upgrades/Downgrades/Cancellations, may be affected during this time.
Please check back for further updates.
Posted Sep 21, 2023 - 13:55 EDT
This incident affected: FreshBooks.