FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Apr 01, 2022 - 15:04 EDT
Update
We’re currently investigating reports of an issue with FreshBooks. You may notice issues with generating PDF's, uploading files & Images to your account or viewing some reports.
We will post updates as soon as we have them.
Posted Apr 01, 2022 - 14:27 EDT
Investigating
We’re currently investigating reports of an issue with PDF generation on FreshBooks. We will post updates as soon as we have them.
Posted Apr 01, 2022 - 13:35 EDT
This incident affected: FreshBooks and Automatic Expense Import.