FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 15, 2021 - 17:42 EDT
Investigating
We’re currently investigating reports of an issue with editing Recurring Templates on FreshBooks. We will post updates as soon as we have them.
Posted Oct 15, 2021 - 16:32 EDT
This incident affected: FreshBooks.