FreshBooks - Trial Accounts Unable to Upgrade
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Trial Upgrades in FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 22, 2021 - 21:41 EDT
Update
We are continuing our work on resolving the issue affecting Trial Upgrades. We appreciate your patience at this time. Please check back for further updates.
Posted May 21, 2021 - 16:59 EDT
Identified
There’s currently an issue with trial accounts having the ability to upgrade on FreshBooks. We’ve identified the cause and are working to fix it, however if your account is currently on a trial, you will not be able to upgrade at this time. Please check back for further updates.
Posted May 21, 2021 - 10:41 EDT
This incident affected: FreshBooks and FreshBooks Classic.