FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Dec 20, 2021 - 09:08 EST
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Dec 17, 2021 - 21:17 EST
Investigating
We’re currently investigating reports of an issue with Client 'Sent Emails' history on FreshBooks. We will post updates as soon as we have them.
Posted Dec 17, 2021 - 14:58 EST
This incident affected: FreshBooks.