FreshBooks Classic - Invoice Email Unavailable
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting sending invoices by email FreshBooks Classic. Thank you for your patience while we worked to fix the issue.
Posted Jun 22, 2021 - 10:21 EDT
Monitoring
We have fixed the issue impacting sending invoices by email in FreshBooks Classic and will continue to monitoring it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Jun 22, 2021 - 09:31 EDT
Identified
We have identified the issue impacting sending invoices by email in FreshBooks Classic, and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Jun 22, 2021 - 09:23 EDT
Investigating
There’s currently an issue with sending invoices by email in FreshBooks Classic. We’ve identified the problem and are working to fix it, however you may be unable to send invoices by email at this time. Please check back for further updates.
Posted Jun 22, 2021 - 09:04 EDT
This incident affected: FreshBooks Classic.