FreshBooks Account Notifications Unavailable
Incident Report for FreshBooks
Resolved
FreshBooks account notifications are now back up and running for all accounts.
Posted 7 months ago. Mar 07, 2018 - 14:38 EST
Identified
We've identified an issue where account notifications will be momentarily unavailable and are currently working to resolve the issue.
Posted 7 months ago. Mar 06, 2018 - 12:23 EST