FreshBooks - Investigating My Team Page Issue

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jun 21, 2023 - 17:30 EDT

Investigating

We’re currently investigating reports of an issue with the "My Team" page and individual Team Member profiles on FreshBooks. We will post updates as soon as we have them.
Posted Jun 21, 2023 - 13:49 EDT
This incident affected: FreshBooks.